Unfortunately, the current version of SyncMate is not compatible with iOS 14 devices. It supports only iOS 5.x–13.x devices.


But we are already working to add support for iOS 14 devices as soon as possible, so stay tuned!